Funk ZV nicht initialisierbar

  • Das müsste ja heißen, dass man ein Grundmodul zusammen mit der Funkeinheit des Schlüssels (hab noch die alten mit Batterie) ja von einem Auto zum anderen übernehmen könnte?!

    Ich habe zwei E39 VFL und ich kann in der Tat den Schlüssel des einen auf den anderen codieren. Damit kann ich ihn auf und zu sperren - mehr natürlich nicht, da der Schlüssel nicht ins Zündschloß paßt.

    Das ist nicht das was ich beschrieben habe...

    Das ich jeden Schlüssel woanders anlernen kann weiß ich.

    Wie ich es geschrieben habe: Grundmodul ZUSAMMEN mit dem Schlüssel tauschen.

    Sprich ich habe Wagen A mit funktionierender Funk-ZV und baue das Grundmodul in Wagen B ein. Kann ich dann einfach ohne Initialisierung mit Schlüssel A Wagen B aufsperren?


    Vielleicht hat jemand beim Umbau die Codierung versemmelt.

    An wen sendet der Empfänger denn das Signal?

    Bei welchem Umbau was versemmelt?

    Und was meinst du mit Sender um Empfänger?

    Der Schlüssel sendet ja einfach "in den Raum" und der Antennenverstärker empfängt alle Signale im 433MHz Band wandelt das Siganl in ein Datenstrom mit 5V Pegel um und sendet den an das Grundmodul.

    Und wenn die Daten übereinstimmen macht das Grundmodul die ZV auf.

    EWS ist ein eigenen System beim e39.


    Soweit zumindest alle Infos die man so finden kann.

    Demnach müsste der angelernte Code nach der Initialisierung ja im Grundmodul gespeichert sein.

    Am Grundmodul ist ein Eingang für Spannung in Radiostellung und auch Eingänge mit Dauerplus und Zündplus.

    Die Frage ist, langt das für das Grundmodul, oder fragt das Grundmodul noch über den Bus andere Zustände von anderen Steuergeräten ab (zb EWS).

    In TIS steht davon zumindest nichts...

    Wie oben schon beschrieben, wenn der Code für die ZV im Grundmodul gespeichert ist, so müsste es sich ja über tragen lassen.

    Die Funk-ZV geht ja auch noch, wenn die Fahrzeugbatterie weg (und das Grundmodul somit stromlos) war und das Grundmodul weiß ja nicht in welchem Auto es verbaut ist, eine VIN seht ja auch nicht darin.


    Nachtrag:

    Am Grundmodul liegt die Spannung für Radiostellung an

    Einmal editiert, zuletzt von hannez () aus folgendem Grund: Ein Beitrag von hannez mit diesem Beitrag zusammengefügt.

  • Habe nochwas in TIS gefunden unter der EWS gefunden:


    "Erhält das EWS3 Steuergerät das Signal "ZV gesichert" vom Grundmodul, so schickt die EWS3 bei Zündschloßposition 1 (Klemme R) über K-Bus ein Signal, das ein Entriegeln des Fahrzeugs bewirkt."


    Das heißt wenn mein Auto abgesperrt ist und ich den Zündschlüssel auf Position 1 mache müsste das Auto sich aufsperren?

    ist das bei jemandem so?

  • Habe leider keinen Lösungsansatz zu genanntem Problem, nur würde ich mich gerne hier einklinken, da ich auch was seltsames erlebt hatte mit meiner Funkfernbedienung.


    Als ich vor ein paar wochen einkaufen wollte habe ich das Auto wie gewohnt per Funk geöffnet.

    Seltsam war, dass er wohl durchgehend noch ein "Signal" bekam welches ihm signalisiert, dass der Knopf angeblich noch aktiviert sei, was nicht der Falk war.

    Somit aktivierte sich die Komfortfunktion dass die Fensterscheiben runtergelassen wurden.

    Konnte seitdem auch nichts mehr mit dem Funk steuern.


    Dachte, die Batterie sei mal wieder leer (Bj.96, 523i Limousine) habe sie somit gewechselt,ohne Erfolg.

    Selbst das Anlernen ging nichtmehr.


    Vielleicht könnte mir da jemand helfen oder wäre da auch das Modul in der C-Säule schuld?


    PS:

    Der aktuelle Fall kann sehr gerne weiter behandelt werden bis eine Lösung für den Ersteller gefunden wurde. Mein Problem hat noch Zeit, da ich auf diesen Komfort ein wenig verzichten kann, da sonst alles geht. :trinken:

  • Also die Scheiben gingen runter? und was passierte danach? Wenn der Taster hängt und fortlaufend "öffnen" sendet, müsste sich die ZV ja wieder aufsperren nachdem mal sie mit dem Schlüssel zugesperrt hat.

    Gingen die Fenster ganz runter? oder hat es dann währenddessen abgebrochen?

  • Also die Scheiben gingen runter? und was passierte danach? Wenn der Taster hängt und fortlaufend "öffnen" sendet, müsste sich die ZV ja wieder aufsperren nachdem mal sie mit dem Schlüssel zugesperrt hat.

    Gingen die Fenster ganz runter? oder hat es dann währenddessen abgebrochen?

    Fenster gingen komplett runter.

    Nach dem Zuschließen mit dem Schlüssel blieb der Wagen auch geschlossen, außer ich habe den Schlüssel nochmal zum öffnen gedreht.

    Fenster blieben an selber Position. Habe dann die Zündung an gemacht und die Fenster wieder hochgefahren.


    Und seither geht das Öffnen und Schließen nurnoch "manuel" ZV geht aber noch einwandfrei, nur wenn ich den Funk nutzen möchte geht es nicht mehr.

    Lämpchen am Schlüssel blinkt, aber den Wagen juckt es nicht.

  • Ich kann euch beiden nur nochmal empfehlen die Tankklappe zu überprüfen. Die hat ein Rücksendesignal.

    Wo siehst du im Schaltplan ein Rücksendesignal?


    Ich sehe in TIS zwei verschiedene Schaltpläne für den Tankdeckel.

    In einer Version hängt der Motor für den Tankdeckverschluss direkt am Grundmodul, in der anderen Version ist es über ein Relais gelöst.

    Wird vom Grundmodul angesteuert - ja, aber Rückmeldung gibt es da doch keine?


    und wie schon öfters erwähnt:

    Sicherung ganz und Tankklappe sperrt ganz normal auf und zu.


    doch das funktioniert!

    es ist ein Unterschied ob an der Tür aber am Schloss abgesperrt wird!


    macht das Fenster auf... sperrt mitm Schlüssel ab... lehnt euch rein und schaltet mitm Schlüssel auf Stellung 1

    dann hört ihr ein ZV Geräusch aber die türpins bleiben unten

    da schaltet er um von "sichern" auf "verriegelt"

    der Unterschied ist dass bei gesichert der Tankdeckel mit abgesperrt ist und ein entriegeln von innen am Centerlock Schalter oder den Türgriffen nicht möglich ist

    2 Mal editiert, zuletzt von hannez () aus folgendem Grund: Ein Beitrag von hannez mit diesem Beitrag zusammengefügt.

  • gestern nochmal Fehlerspeicher ausgelesen.

    Im GM steht nichts.

    Aber im EWS steht:

    15 POWER-ON-RESET statischer Fehler

    gelöscht - kam gleich wieder.


    Aber starten funktioniert! und EWS muss auch aktiv sein, wenn ich den EWS-Transponder aus dem Schlüssel raus nehme startet er nicht.

    Und einen Zusammenhang zur Funk-ZV sehe ich auch nicht.

  • habe immer noch keine Lösung
    nur eben die Theorie, dass mein GM wegen der nicht passenden EWS nicht in die initalisierung gehen möchte.

    Ich würde jetzt gerne mal mein GM in einen anderen e39 bauen - dort die Funk ZV anlernen und dann zurück bauen.

    Müsste doch gehen oder nicht?! Im GM steht keine Fahrgestellnummer, Funk ZV geht auch nach abklemmen der Batterie noch, also weiß das GM doch gar nicht wo es verbaut bzw angelernt wurde oder nicht?!


    Wer kommt denn aus der Nähe Forchheim (91301) und hätte mal Zeit, Lust und eben so viel Neugier wie ich ;) ??

  • Im GM steht keine Fahrgestellnummer, Funk ZV geht auch nach abklemmen der Batterie noch, also weiß das GM doch gar nicht wo es verbaut bzw angelernt wurde oder nicht?!

    Darauf würde ich keinen Pfennig wetten!

    Alle Steuergeräte müssen angelernt werden und wo genau alles der KM-Stand steht wissen auch nicht wirklich alle.

  • Im GM steht keine Fahrgestellnummer, Funk ZV geht auch nach abklemmen der Batterie noch, also weiß das GM doch gar nicht wo es verbaut bzw angelernt wurde oder nicht?!

    Darauf würde ich keinen Pfennig wetten!

    Alle Steuergeräte müssen angelernt werden und wo genau alles der KM-Stand steht wissen auch nicht wirklich alle.

    Jein :D


    Also Codierwissen, sowie Hardware und Software sind vorhanden - keine Sorge. TIS, sowie Schaltpläne studiert usw...


    FGN steht im Kombi, im LCM und in EWS. Das weiß jeder ;)

    Das GM muss codiert werden, das ist richtig. Aber die grundlegende Funktion "Funk ZV" hat gar keinen Codierwert im GM. (ok Stimmt nicht ganz - es gibt einen Wert für Japan, dort wurde statt funk Infrarot verbaut - andere Geschichte)
    Wenn man das Grundmodul tauscht, dann können grundmodulabhängige Funktionen nicht gehen, das ist richtig. Aber geht ja "nur" um die FunkZV.

    Und so langsam ist das hald meine letzte Hoffnung. Siehe Beiträge oben - schon ALLES versucht.